All services are now operating normally, and users should no longer experience any issues. We apologize for any inconvenience caused and appreciate your patience during this time. If you continue to encounter any problems, please contact our support team.
Posted Jun 24, 2025 - 20:58 CEST
Identified
We are currently experiencing a major outage affecting our Account Management services. Users are unable to access or manage their account settings, including profile updates, password changes, and authentication processes. Our engineering team is actively investigating the root cause and working diligently to restore full functionality. We understand the inconvenience this may cause and sincerely apologize for the disruption. Further updates will be provided as more information becomes available.
Posted Jun 24, 2025 - 20:13 CEST
This incident affected: User Accounts & Licenses (Account Management).